Verify your First order after it has been delivered

Hi All,

I have been trying to verify my first order for a while now. Just wondering what I am missing. I have set up the Importers and I have received the stock and it is now being delivered to my shops. I still can’t move past this challenge from Uncle Fred. What button have I not clicked?

You need to go to your warehouse and walk inside after the delivery has been made. If that doesn’t work, try saving and reloading!

and alle the items from the quest has to be in the warehouse
when you goods has ben deliver to shops you cant verify them

1 Like

Awesome, Thank you very much. I will try and save and reload, but I don’t think they are there anymore.


Just want to say that this is a bit of a bug as well, cause I did go into the warehouse and I had to distribute the goods myself, because for whatever reason the goods where not being sent out. I have seen online that having the van to close to the back wall in parking bay can cause this and now wondering if this was the problem all along. Thanks for your help though and I hope this can help others.

1 Like

Follow up on this - did you already have Logistics Manager set up with a delivery driver before doing this quest? If so, the problem is, you already told it to ship out your product before checking it, so when you get there, you don’t have the amount you’re supposed to be looking for.

Had same issue. Looks like you simply need to have at lest 600 soda cans and 1000 cheap gifts in warehouse when you enter it, to complete the objective. So you simply need to order some more if it was distributed already.

1 Like

I had this probme as well, as most of the products was heading out to stores with the delivery driver, I was confused… took me 30 minutes to figure it out why it wasn’t counting it. And it is my third playthrough…

1 Like

I have tried saving and reloading 3 times now and it seems that it is still not working. I have the exact same issue as the fellow above.

Oh the people above were playing a completely different version of the game - you’re not experiencing that same thing now! However - make sure you’re playing the most recent patches, because this should be fixed after the recent patches!